summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Weißschuh <thomas@t-8ch.de>2023-01-19 03:07:06 +0000
committerDudemanguy <random342@airmail.cc>2023-01-19 22:15:14 +0000
commit2056bf1b4e72c5350182e4b150ec1317431cf921 (patch)
tree4bcd075b8395e6ecc645bf089c5301df73a17f3b /meson.build
parentfd2f1a6f9af5087ca8e6e878176db6308fd4b45a (diff)
downloadmpv-2056bf1b4e72c5350182e4b150ec1317431cf921.tar.bz2
mpv-2056bf1b4e72c5350182e4b150ec1317431cf921.tar.xz
meson: add simple test executable for libmpv
This can be used to make sure that the built libmpv is functional.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 99e848fabc..4b9892e5bc 100644
--- a/meson.build
+++ b/meson.build
@@ -1683,6 +1683,9 @@ if get_option('libmpv')
headers = ['libmpv/client.h', 'libmpv/render.h',
'libmpv/render_gl.h', 'libmpv/stream_cb.h']
install_headers(headers, subdir: 'mpv')
+
+ libmpv_test = executable('libmpv-test', 'libmpv/test.c', link_with: [libmpv])
+ test('libmpv', libmpv_test)
endif
if get_option('cplayer')