summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAaron Boxer <boxerab@protonmail.com>2022-05-18 10:35:53 -0400
committerDudemanguy <random342@airmail.cc>2022-05-24 21:39:34 +0000
commitdefb02daa461200f4de972c57c4ac8dc108feb5f (patch)
tree0f6725f695b3d8be240c71bc1c5e35aacc3fdb8c /meson.build
parent9022b1b51dc1204760f9d495e7b3b5550f501bf3 (diff)
downloadmpv-defb02daa461200f4de972c57c4ac8dc108feb5f.tar.bz2
mpv-defb02daa461200f4de972c57c4ac8dc108feb5f.tar.xz
vo: add new vaapi-wayland driver
This driver makes use of dmabuffer and viewporter interfaces to enable efficient display of vaapi surfaces, avoiding any unnecessary colour space conversion, and avoiding scaling or colour conversion using GPU shader resources.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 25f399da64..0b07582a33 100644
--- a/meson.build
+++ b/meson.build
@@ -1432,10 +1432,16 @@ vaapi_wayland = {
'deps': dependency('libva-wayland', version: '>= 1.1.0', required: get_option('vaapi-wayland')),
}
vaapi_wayland += {'use': vaapi['use'] and egl_wayland['use'] and vaapi_wayland['deps'].found()}
+
if vaapi_wayland['use']
features += vaapi_wayland['name']
endif
+if vaapi_wayland['use'] and memfd_create
+ features += 'vaapi-wayland-memfd'
+ sources += files('video/out/vo_vaapi_wayland.c')
+endif
+
vaapi_x11 = {
'name': 'vaapi-x11',
'deps': dependency('libva-x11', version: '>= 1.1.0', required: get_option('vaapi-x11')),