summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-10-18 11:16:51 -0500
committerDudemanguy <random342@airmail.cc>2023-10-19 12:10:53 -0500
commitd5e5c2ce9821db344c6744a33cec5068fe4bbeb3 (patch)
tree1f2d5b53ba3d36b45ae8ca08c270f0021805fca5 /meson.build
parentbd1ba99ab2f64f218128100cbf3a91e5cb1b4872 (diff)
downloadmpv-d5e5c2ce9821db344c6744a33cec5068fe4bbeb3.tar.bz2
mpv-d5e5c2ce9821db344c6744a33cec5068fe4bbeb3.tar.xz
stream_cdda: remove fallback for ancient libcdio versions
CDIO_API_VERSION 6 has been around since libcdio 0.90. That was release over a decade ago. There's literally no reason to keep the ugly mess of the old api around so remove it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d6c76f3b08..ca3df9f1f0 100644
--- a/meson.build
+++ b/meson.build
@@ -590,10 +590,11 @@ cdda_opt = get_option('cdda').require(
get_option('gpl'),
error_message: 'the build is not GPL!',
)
+cdio = dependency('libcdio', version: '>= 0.90', required: cdda_opt)
cdda = dependency('libcdio_paranoia', required: cdda_opt)
-features += {'cdda': cdda.found()}
+features += {'cdda': cdda.found() and cdio.found()}
if features['cdda']
- dependencies += cdda
+ dependencies += [cdda, cdio]
sources += files('stream/stream_cdda.c')
endif