summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorsfan5 <sfan5@live.de>2021-11-20 20:59:37 +0100
committersfan5 <sfan5@live.de>2021-11-22 18:08:56 +0100
commitd5d62c6a6459412c86bd8d09be248810364a2405 (patch)
tree9ee6ee69c48286b9acccf3957e2114b705c31b03 /meson.build
parentf32ea013dd41a1baa59c1cd696ed29ce21baca99 (diff)
downloadmpv-d5d62c6a6459412c86bd8d09be248810364a2405.tar.bz2
mpv-d5d62c6a6459412c86bd8d09be248810364a2405.tar.xz
vo_gpu_next: factor out context-specific code to gpu_next/context.c
This is done to avoid cluttering vo_gpu_next.c with more ifdeffery and context-specific code when additional backends are added in the near future. Eventually gpu_ctx is intended to take the place of ra_ctx to further separate gpu and gpu_next.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c49700f463..c3a7ca89f1 100644
--- a/meson.build
+++ b/meson.build
@@ -979,7 +979,8 @@ if libplacebo.found()
features += 'libplacebo-v4'
libplacebo_v4 = true
message('libplacebo v4.170+ found! Enabling vo_gpu_next.')
- sources += files('video/out/vo_gpu_next.c')
+ sources += files('video/out/vo_gpu_next.c',
+ 'video/out/gpu_next/context.c')
else
message('libplacebo v4.170+ not found! Disabling vo_gpu_next.')
endif