summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.dev>2022-02-22 20:04:31 +0100
committerNiklas Haas <github-daiK1o@haasn.dev>2022-02-25 22:13:20 +0100
commitb1fb4b783bd604ffb763e88a7cee2ad9d9c2c209 (patch)
treece29f237690592dc547ddba21af3476b4ded5bf2 /meson.build
parent626fa506d5237cd178e3fb5dbd524e73ad449ee8 (diff)
downloadmpv-b1fb4b783bd604ffb763e88a7cee2ad9d9c2c209.tar.bz2
mpv-b1fb4b783bd604ffb763e88a7cee2ad9d9c2c209.tar.xz
vo_gpu_next: remove/simplify plane flipping hacks
libplacebo v198 fixed this properly by adding the ability to flip planes directly, which is done automatically by the swapchain helpers. As such, we no longer need to concern ourselves with hacky logic to flip planes using the crop. This also removes the need for the OSD coordinate hack on OpenGL.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 10cfa54a90..2af8111c3e 100644
--- a/meson.build
+++ b/meson.build
@@ -965,14 +965,14 @@ if libplacebo.found()
sources += files('video/out/placebo/ra_pl.c',
'video/out/placebo/utils.c')
pl_api_ver = libplacebo.version().split('.')[1]
- if pl_api_ver.version_compare('>=197')
+ if pl_api_ver.version_compare('>=199')
features += 'libplacebo-next'
libplacebo_next = true
- message('libplacebo v4.197+ found! Enabling vo_gpu_next.')
+ message('libplacebo v4.199+ found! Enabling vo_gpu_next.')
sources += files('video/out/vo_gpu_next.c',
'video/out/gpu_next/context.c')
else
- message('libplacebo v4.197+ not found! Disabling vo_gpu_next.')
+ message('libplacebo v4.199+ not found! Disabling vo_gpu_next.')
endif
endif