summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNiklas Haas <git@haasn.dev>2022-01-03 03:56:36 +0100
committerNiklas Haas <github-daiK1o@haasn.dev>2022-01-07 06:28:14 +0100
commita9cb2e2821adb40e7548e8233390e79706104041 (patch)
tree382cee5ce44b9c6cf3ae196e23e908c4718ebbea /meson.build
parent57bc5ba6d6579d5f1e6897f6915a3a940b84bb73 (diff)
downloadmpv-a9cb2e2821adb40e7548e8233390e79706104041.tar.bz2
mpv-a9cb2e2821adb40e7548e8233390e79706104041.tar.xz
vo_gpu_next: update for new tone mapping options
This was significantly refactored upstream. Switch to new APIs and add new tone mapping curves and options. cf. https://code.videolan.org/videolan/libplacebo/-/merge_requests/212
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 407fd1ddea..a04fda3172 100644
--- a/meson.build
+++ b/meson.build
@@ -977,14 +977,14 @@ if libplacebo.found()
sources += files('video/out/placebo/ra_pl.c',
'video/out/placebo/utils.c')
pl_api_ver = libplacebo.version().split('.')[1]
- if pl_api_ver.version_compare('>=170')
+ if pl_api_ver.version_compare('>=190')
features += 'libplacebo-v4'
libplacebo_v4 = true
- message('libplacebo v4.170+ found! Enabling vo_gpu_next.')
+ message('libplacebo v4.190+ found! Enabling vo_gpu_next.')
sources += files('video/out/vo_gpu_next.c',
'video/out/gpu_next/context.c')
else
- message('libplacebo v4.170+ not found! Disabling vo_gpu_next.')
+ message('libplacebo v4.190+ not found! Disabling vo_gpu_next.')
endif
endif