summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-10-21 09:53:54 -0500
committerDudemanguy <random342@airmail.cc>2023-11-09 18:12:25 +0000
commita5bf211e128b4fb916edcf5f46bd23d3ff222711 (patch)
tree12ee77e7630c4995bc2060445936b8bbe1096c57 /meson.build
parent051ba909b4107240d643e4793efa2ceb714fd1b4 (diff)
downloadmpv-a5bf211e128b4fb916edcf5f46bd23d3ff222711.tar.bz2
mpv-a5bf211e128b4fb916edcf5f46bd23d3ff222711.tar.xz
meson: remove several macos-10-* build options
These have been build options since the waf build, but that doesn't really make sense. The build can detect whatever macOS sdk version is available and then use that information to determine whether to enable the features or not. Potentially disabling multiple sdk versions doesn't really make any sense. Because f5ca11e12bc55d14bd6895b619c4abfd470c6452 effectively made macOS 10.15 the minimum supported version, we can drop all of these checks and bump the required sdk version to 10.15. The rest of the build simplifies from there.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 3 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index da051b7d91..f9c29cdaa8 100644
--- a/meson.build
+++ b/meson.build
@@ -1498,23 +1498,8 @@ sys.stdout.write(swift_ver)
message('Detected Swift version: ' + swift_ver)
endif
-macos_10_11_features = get_option('macos-10-11-features').require(
- macos_sdk_version.version_compare('>=10.11'),
- error_message: 'a suitable macos sdk version could not be found!',
-)
-
-macos_10_12_2_features = get_option('macos-10-12-2-features').require(
- macos_sdk_version.version_compare('>=10.12.2'),
- error_message: 'a suitable macos sdk version could not be found!',
-)
-
-macos_10_14_features = get_option('macos-10-14-features').require(
- macos_sdk_version.version_compare('>=10.14'),
- error_message: 'a suitable macos sdk version could not be found!',
-)
-
swift = get_option('swift-build').require(
- darwin and macos_sdk_version.version_compare('>=10.10') and swift_ver.version_compare('>=4.1'),
+ darwin and macos_sdk_version.version_compare('>= 10.15') and swift_ver.version_compare('>= 4.1'),
error_message: 'A suitable macos sdk version or swift version could not be found!',
)
features += {'swift': swift.allowed()}
@@ -1549,8 +1534,8 @@ if features['cocoa'] and features['vulkan'] and features['swift']
endif
macos_media_player = get_option('macos-media-player').require(
- macos_10_12_2_features.allowed() and features['swift'],
- error_message: 'Either the macos sdk version is not at least 10.12.2 or swift was not found!',
+ features['swift'],
+ error_message: 'Swift was not found!',
)
features += {'macos-media-player': macos_media_player.allowed()}
if features['macos-media-player']