summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-07-23 15:05:59 -0500
committerDudemanguy <random342@airmail.cc>2023-07-23 22:00:08 +0000
commit9e449cc685fd0635ebed906acda0446b43db2f59 (patch)
tree6f68c76989f7bc0c9f7ce873b1a40b3695653c1f /meson.build
parentf2cce5f38f4031bf1a4b4919ec90e4e8f8c66a77 (diff)
downloadmpv-9e449cc685fd0635ebed906acda0446b43db2f59.tar.bz2
mpv-9e449cc685fd0635ebed906acda0446b43db2f59.tar.xz
build: internally rename gl-wayland to egl-wayland
This has always been a pet peeve of mine and in fact I named the option in meson "egl-wayland" with the intention of finally doing this. We call everything that's egl "egl-foo" internally except for wayland.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index f9fe4e7263..de396b9f1f 100644
--- a/meson.build
+++ b/meson.build
@@ -1197,8 +1197,8 @@ if features['egl-drm']
endif
egl_wayland = dependency('wayland-egl', version: '>= 9.0.0', required: get_option('egl-wayland'))
-features += {'gl-wayland': features['egl'] and egl_wayland.found() and gl_allowed and features['wayland']}
-if features['gl-wayland']
+features += {'egl-wayland': features['egl'] and egl_wayland.found() and gl_allowed and features['wayland']}
+if features['egl-wayland']
dependencies += egl_wayland
features += {'gl': true}
sources += files('video/out/opengl/context_wayland.c')
@@ -1411,7 +1411,7 @@ if features['vaapi-drm']
endif
vaapi_wayland = dependency('libva-wayland', version: '>= 1.1.0', required: get_option('vaapi-wayland').require(features['vaapi']))
-features += {'vaapi-wayland': features['vaapi'] and features['gl-wayland'] and vaapi_wayland.found()}
+features += {'vaapi-wayland': features['vaapi'] and features['egl-wayland'] and vaapi_wayland.found()}
if features['vaapi-wayland']
dependencies += vaapi_wayland
endif