summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKacper Michajłow <kasper93@gmail.com>2023-03-30 15:24:22 +0200
committerJan Ekström <jeebjp@gmail.com>2023-04-02 21:23:48 +0300
commit9d120a441191870cbb734a6769478eb4aadd701e (patch)
treeb398b013defab12b7386b2a039cac33bc9ff94a7 /meson.build
parent911d742817fc05be39706d42d32647eb91e8fdde (diff)
downloadmpv-9d120a441191870cbb734a6769478eb4aadd701e.tar.bz2
mpv-9d120a441191870cbb734a6769478eb4aadd701e.tar.xz
build: add check for eglext_angle.h when checking for ANGLE
This better follows the actual required bits, and makes sure that a file not part of standard EGL headers is available, as the handle type is part of standard EGL extensions header.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 8 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index ac8af51d59..92be68c529 100644
--- a/meson.build
+++ b/meson.build
@@ -1104,9 +1104,14 @@ if features['gl-dxinterop']
endif
egl_angle = get_option('egl-angle').require(
- features['gl-win32'] and cc.has_header_symbol('EGL/eglext.h',
- 'EGL_D3D_TEXTURE_2D_SHARE_HANDLE_ANGLE',
- prefix: '#include <EGL/egl.h>'),
+ features['gl-win32'] and
+ cc.has_header_symbol('EGL/eglext.h',
+ 'EGL_D3D_TEXTURE_2D_SHARE_HANDLE_ANGLE',
+ prefix: '#include <EGL/egl.h>') and
+ cc.has_header_symbol('EGL/eglext_angle.h',
+ 'PFNEGLCREATEDEVICEANGLEPROC',
+ # TODO: change to list when meson 1.0.0 is required
+ prefix: '#include <EGL/egl.h>\n#include <EGL/eglext.h>'),
error_message: 'egl-angle could not be found!',
)
features += {'egl-angle': egl_angle.allowed()}