summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorsyphyr <syphyr@gmail.com>2023-09-09 20:54:40 +0200
committersfan5 <sfan5@live.de>2023-09-13 00:00:57 +0200
commit662650bde319a57733bb4ea80f709a018d247f1d (patch)
tree39d22967aaf0bd93b677edb6702a5fb08697cb79 /meson.build
parent97dc20278713ef66eb0201e2d3324935ea68daae (diff)
downloadmpv-662650bde319a57733bb4ea80f709a018d247f1d.tar.bz2
mpv-662650bde319a57733bb4ea80f709a018d247f1d.tar.xz
meson: check vulkan version
The symbol "vkGetPhysicalDeviceProperties2" was recently added after refactoring context.c.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8a0f9ba102..546893f615 100644
--- a/meson.build
+++ b/meson.build
@@ -1263,7 +1263,7 @@ vulkan_opt = get_option('vulkan').require(
libplacebo.get_variable('pl_has_vulkan', default_value: '0') == '1',
error_message: 'libplacebo could not be found!',
)
-vulkan = dependency('vulkan', required: vulkan_opt)
+vulkan = dependency('vulkan', version: '>= 1.1.70', required: vulkan_opt)
features += {'vulkan': vulkan.found()}
if features['vulkan']
dependencies += vulkan