summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-10-20 17:13:50 -0500
committerDudemanguy <random342@airmail.cc>2023-10-21 14:05:38 +0000
commit57fedcfcdaaebc4c8f1a28db001371167f9d708c (patch)
tree8686d37d89cf3ba2814affeb0ce0e67ef3597b97 /meson.build
parent94b67355c20ef61876e24f64709ada79334fb487 (diff)
downloadmpv-57fedcfcdaaebc4c8f1a28db001371167f9d708c.tar.bz2
mpv-57fedcfcdaaebc4c8f1a28db001371167f9d708c.tar.xz
meson: remove -D_ISOC99_SOURCE flag
The meson build has always compiled with c_std=c11. This was never really needed.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ba9e0caa0f..1067284e7f 100644
--- a/meson.build
+++ b/meson.build
@@ -251,8 +251,7 @@ sources = files(
# compiler stuff
cc = meson.get_compiler('c')
-flags = ['-D_ISOC99_SOURCE', '-D_GNU_SOURCE',
- '-D_FILE_OFFSET_BITS=64']
+flags = ['-D_GNU_SOURCE', '-D_FILE_OFFSET_BITS=64']
link_flags = []
test_flags = ['-Werror=implicit-function-declaration',