summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2023-08-12 19:30:11 -0500
committerDudemanguy <random342@airmail.cc>2023-08-20 02:01:39 +0000
commit200992f90c49fdc2d5605cf79ffaa5247fd62e3e (patch)
tree480bd98e2cab6a93fa80616019b140883ab4ff77 /meson.build
parenta0038504a3ef408304f87cda32f3aec7cd9975e3 (diff)
downloadmpv-200992f90c49fdc2d5605cf79ffaa5247fd62e3e.tar.bz2
mpv-200992f90c49fdc2d5605cf79ffaa5247fd62e3e.tar.xz
x11: remove xinerama and refactor window geometry
mpv mixes xinerama and randr usage together which gets kind of confusing and is also pretty stupid. Xinerama is completely unneccesary today since randr can do everything it can do and much more. Remove it. This reworks a lot of the window/geometry handling stuff to be centered completely around xrandr_display plus some other tweaks to the geometry handling. An important concept is that current_icc_screen is changed into current_screen and used more generously since it is useful for things besides just icc profiles.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1a92ef9f40..d7dec116f1 100644
--- a/meson.build
+++ b/meson.build
@@ -1035,7 +1035,6 @@ x11 = {
'deps': [dependency('x11', version: '>= 1.0.0', required: x11_opt),
dependency('xscrnsaver', version: '>= 1.0.0', required: x11_opt),
dependency('xext', version: '>= 1.0.0', required: x11_opt),
- dependency('xinerama', version: '>= 1.0.0', required: x11_opt),
dependency('xpresent', version: '>= 1.0.0', required: x11_opt),
dependency('xrandr', version: '>= 1.4.0', required: x11_opt)],
}