summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorKacper Michajłow <kasper93@gmail.com>2023-10-22 03:58:13 +0200
committerDudemanguy <random342@airmail.cc>2023-11-05 17:36:17 +0000
commit1e0aaab78cdb94799878be73833617d0c4253c64 (patch)
tree67ea05fcba2ae77b03b37941d7ea40ed3ebc1b3c /meson.build
parent56d35da180879ef86a15f89f1f870dcc1cb11e5f (diff)
downloadmpv-1e0aaab78cdb94799878be73833617d0c4253c64.tar.bz2
mpv-1e0aaab78cdb94799878be73833617d0c4253c64.tar.xz
threads: move pthread debug to threads-posix.h
And remove redundant define while at it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index d23914475e..e0f7fd7b91 100644
--- a/meson.build
+++ b/meson.build
@@ -367,9 +367,6 @@ pthread_debug = get_option('pthread-debug').require(
error_message: 'win32-threads was found!',
)
features += {'pthread-debug': pthread_debug.allowed()}
-if features['pthread-debug']
- flags += '-DMP_PTHREAD_DEBUG'
-endif
add_project_arguments(flags, language: 'c')
add_project_link_arguments(link_flags, language: ['c', 'objc'])