summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlexandre Ratchov <alex@caoua.org>2023-07-24 16:01:25 -0400
committerDudemanguy <random342@airmail.cc>2023-07-30 19:28:14 +0000
commit1bbc7a2cd086e025d66d8f70e2399c58d26e9972 (patch)
tree37eee4953f788b6838c5590969d103d338652a4e /meson.build
parentb7bf5e619fc94ebea6dac6fff4336561fb221fbc (diff)
downloadmpv-1bbc7a2cd086e025d66d8f70e2399c58d26e9972.tar.bz2
mpv-1bbc7a2cd086e025d66d8f70e2399c58d26e9972.tar.xz
ao_sndio: use sio_flush() to improve controls responsiveness
Use sio_flush() instead of sio_stop() to improve controls responsiveness.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a584ec15f1..62b98b60a5 100644
--- a/meson.build
+++ b/meson.build
@@ -857,6 +857,7 @@ endif
sndio = dependency('sndio', required: get_option('sndio'))
features += {'sndio': sndio.found()}
+features += {'sndio-1-9': sndio.version().version_compare('>= 1.9.0')}
if features['sndio']
dependencies += sndio
sources += files('audio/out/ao_sndio.c')