summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDudemanguy <random342@airmail.cc>2021-11-15 08:04:18 -0600
committerDudemanguy <random342@airmail.cc>2021-11-15 16:58:23 +0000
commit3bfc37dcb46b43e44ff4f99d1947ccfd603379b9 (patch)
tree7de6bb03617c8a78a74705f309bb5af9747b646d /meson.build
parent257bc952556e6ba553713e1209c6528978ece56b (diff)
downloadmpv-3bfc37dcb46b43e44ff4f99d1947ccfd603379b9.tar.bz2
mpv-3bfc37dcb46b43e44ff4f99d1947ccfd603379b9.tar.xz
meson: check for x11 when building the xv option
Obvious oversight in the original PR for the meson build. The xv option requires x11 to function. Check for this by using the require method.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2e08d9d660..5b181e45d7 100644
--- a/meson.build
+++ b/meson.build
@@ -1088,7 +1088,11 @@ if x11['use']
'video/out/x11_common.c')
endif
-xv = dependency('xv', required: get_option('xv'))
+xv_opt = get_option('xv').require(
+ x11['use'],
+ error_message: 'x11 could not be found!',
+)
+xv = dependency('xv', required: xv_opt)
if xv.found()
dependencies += xv
features += 'xv'