summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 61a8533..4c7e37d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,6 @@ AC_CONFIG_HEADER([config.h])
# Checks for programs.
AC_PROG_CC
-AC_PROG_CXX
AC_PROG_CPP
AM_PROG_CC_C_O
AM_PROG_AS
@@ -178,14 +177,12 @@ fi
if test x$enable_directwrite != xno; then
-AC_LANG_PUSH([C++])
-CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
# Linking to DirectWrite directly only works from Windows
AC_MSG_CHECKING([for DIRECTWRITE])
AC_LINK_IFELSE([
AC_LANG_PROGRAM(
- [[#include <dwrite.h>]],
- [[DWRITE_FACTORY_TYPE_SHARED;]],)
+ [[#include <windows.h>]],
+ [[;]],)
], [
AC_DEFINE(CONFIG_DIRECTWRITE, 1, [found DirectWrite])
directwrite=true
@@ -194,7 +191,6 @@ AC_LINK_IFELSE([
directwrite=false
AC_MSG_RESULT([no])
])
-AC_LANG_POP([C++])
fi
AM_CONDITIONAL([DIRECTWRITE], [test x$directwrite = xtrue])