summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7186578..d97cb98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,6 +322,9 @@ AM_CONDITIONAL([DIRECTWRITE], [test "x$directwrite" = xtrue])
## Define C Macros not relating to libraries
AM_COND_IF([ASM], [
AC_DEFINE(CONFIG_ASM, 1, [ASM enabled])
+ AM_COND_IF([X86], [
+ AC_DEFINE(ARCH_X86, 1, [targeting a 32- or 64-bit x86 host architecture])
+ ])
], [
AC_DEFINE(CONFIG_ASM, 0, [ASM enabled])
])