summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorwm4 <wm4@nowhere>2015-10-12 21:56:44 +0200
committerwm4 <wm4@nowhere>2015-10-12 23:01:32 +0200
commitde4ea4bbd1c5101bf0b572a4facd58875845f495 (patch)
treec01bef70635acc11dcc10798bc86528e0d21c1ba /libass/Makefile.am
parent4778001b673c73133d7d1dd48a385d0ca424ccfc (diff)
downloadlibass-de4ea4bbd1c5101bf0b572a4facd58875845f495.tar.bz2
libass-de4ea4bbd1c5101bf0b572a4facd58875845f495.tar.xz
ass: use a bitmap for checking duplicate events
The loop in check_duplicate_event() essentially makes event processing with ass_process_chunk() O(n^2). Using a bitmap instead of a loop brings it back to O(n). This could be interpreted as an API change: since the event list is freely modifieable by the API user through ASS_Track public fields, libass can't know if the internal bitmap went out of sync with the public event list. We just redefine it so that calling ass_process_chunk() means the API user agrees not to manipulate the event list otherwise.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index c0e4692..43e825d 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -3,7 +3,7 @@ AM_CFLAGS = -std=gnu99 -Wall -Wextra -Wno-sign-compare -Wno-unused-parameter \
-Wpointer-arith -Wredundant-decls -D_GNU_SOURCE
LIBASS_LT_CURRENT = 7
-LIBASS_LT_REVISION = 0
+LIBASS_LT_REVISION = 1
LIBASS_LT_AGE = 2
yasm_verbose = $(yasm_verbose_$(V))