summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2009-06-29 14:16:46 +0200
committerGrigori Goronzy <greg@blackbox>2009-06-29 14:25:33 +0200
commitcddd9ad1c3a27d1f055a1aa91004feff27ab8f1a (patch)
tree29f075ca335c390cb7af3e8724591ea38e592b9e /libass/Makefile.am
parent00983363e4356fd4bd0da3659f37707b31fc6597 (diff)
downloadlibass-cddd9ad1c3a27d1f055a1aa91004feff27ab8f1a.tar.bz2
libass-cddd9ad1c3a27d1f055a1aa91004feff27ab8f1a.tar.xz
Restrict symbols exported in the DSO
Only export those symbols into the shared object which are defined in the API (ass.h). A file libass.sym which contains a list of symbols was added and libtool configured to use it.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index 8703f6a..ccdeebc 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -8,6 +8,7 @@ libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontconfig.c ass_render.c \
ass_cache.h ass_fontconfig.h ass_font.h ass.h \
ass_library.h ass_types.h ass_utils.h help_mp.h
libass_la_LDFLAGS = -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
+libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym
assheadersdir = $(includedir)/ass
dist_assheaders_HEADERS = ass.h ass_types.h