summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2010-01-03 14:54:02 +0100
committerGrigori Goronzy <greg@blackbox>2010-01-05 23:52:02 +0100
commit9826dd0f7cc53881de23fac317a7190e47f78401 (patch)
treec97999e1eafe6fdbc7747921ffc1c77d28561ab6 /libass/Makefile.am
parent4f791cc8c8e2f0a5ab8bd8fbd1c85d007a17830e (diff)
downloadlibass-9826dd0f7cc53881de23fac317a7190e47f78401.tar.bz2
libass-9826dd0f7cc53881de23fac317a7190e47f78401.tar.xz
Replace strtod with locale-independent strtod
strtod respects the locale and in some locales, the decimal separator is not a point, leading to parsing errors in tags like \pos(23.4,5), which are perfectly valid. As there isn't a really portable way to use a particular locale just for one call to strtod, reimplement it. The implementation was taken from the 1.8 branch of Ruby.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index 0cf613e..10b5c5b 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -8,7 +8,7 @@ libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontconfig.c ass_render.c \
ass_cache.h ass_fontconfig.h ass_font.h ass.h \
ass_library.h ass_types.h ass_utils.h ass_drawing.c \
ass_drawing.h ass_cache_template.h ass_render.h \
- ass_parse.c ass_parse.h
+ ass_parse.c ass_parse.h ass_strtod.c
libass_la_LDFLAGS = -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym