summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2011-07-06 23:19:54 +0200
committerGrigori Goronzy <greg@blackbox>2011-07-06 23:24:30 +0200
commit3bb8743641c398e0807322ea74754d7e54fbbc3d (patch)
treee922f720492f52868fa7031fcbb63c18299714b1 /libass/Makefile.am
parent87d472953d5eb58a0e0b8d6414e7ffcd3678d83a (diff)
downloadlibass-3bb8743641c398e0807322ea74754d7e54fbbc3d.tar.bz2
libass-3bb8743641c398e0807322ea74754d7e54fbbc3d.tar.xz
Provisional bidi and shaping support
Adds fully working bidirectional text and simple shaping support. The following works: - bidirectional text according to the Unicode Bidirectional Algorithm - simple shaper for mirrored forms (brackets, etc.) according to rule L4 of the Unicode Bidirectional Algorithm - reordering into visual order with correct line wrapping However, the implementation certainly needs efficiency improvements (caching, less malloc'ing), a proper shaper (HarfBuzz) needs to be hooked up and various bugs with karaoke and positioning need to be fixed.
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index 375f8e6..142de68 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -10,7 +10,8 @@ libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontconfig.c ass_render.c \
ass_cache.h ass_fontconfig.h ass_font.h ass.h \
ass_library.h ass_types.h ass_utils.h ass_drawing.c \
ass_drawing.h ass_cache_template.h ass_render.h \
- ass_parse.c ass_parse.h ass_render_api.c ass_strtod.c
+ ass_parse.c ass_parse.h ass_render_api.c ass_shaper.c \
+ ass_shaper.h ass_strtod.c
libass_la_LDFLAGS = -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym