summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2009-07-06 04:13:24 +0200
committerGrigori Goronzy <greg@blackbox>2009-07-06 04:29:40 +0200
commit323e6cefb6e2c7dfd82ef397fffe395f7b3e49ef (patch)
tree693035dde8afc0eddb463c3731bde4bd08c9c2f1 /libass/Makefile.am
parentcbf59032a582b37e50490e3eea0cf3cf8532c418 (diff)
downloadlibass-323e6cefb6e2c7dfd82ef397fffe395f7b3e49ef.tar.bz2
libass-323e6cefb6e2c7dfd82ef397fffe395f7b3e49ef.tar.xz
Implement drawing mode (\p)
Finally implement the drawing mode, which allows drawing of custom vector graphics. Drawings are intercepted in ass_render_event; a hash of the drawing string is generated which is then used for looking up drawings and bitmaps of drawings in the cache. The drawings itself are "fake" glyphs. They are created by parsing the simple drawing description language, evaluating the curves described (lines, cubic beziers and/or a special kind of b-splines) and creating vector outlines. Afterwards, these drawings are (with a few exceptions, e.g. ascender/descender) exactly handled like regular glyphs. Support for vector clippings is still missing, but otherwise the implementation should be complete and compatible with VSFilter. The libass integration of the drawing parsing/processing code is still a bit sketchy and should be refactored. History: WIP: Drawing mode infrastructure WIP: Drawing tokenizer WIP: Parse drawing tokens, call evaluators WIP: Bezier/b-spline evaluator WIP: Final pieces for the drawing mode WIP: Heavy modifications to the drawing parser/tokenizer WIP: Dynamic outline memory allocation WIP: Drawing position fixes WIP: more drawing position fixup (similar to VSFilter now) WIP: Lots of cleanup and fixes for drawings. WIP: Drawing mode integration into ass_render_event
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index ccdeebc..81b8b96 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -6,7 +6,8 @@ lib_LTLIBRARIES = libass.la
libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontconfig.c ass_render.c \
ass_utils.c ass_bitmap.c ass_library.c ass_bitmap.h \
ass_cache.h ass_fontconfig.h ass_font.h ass.h \
- ass_library.h ass_types.h ass_utils.h help_mp.h
+ ass_library.h ass_types.h ass_utils.h ass_drawing.c \
+ ass_drawing.h help_mp.h
libass_la_LDFLAGS = -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym