summaryrefslogtreecommitdiffstats
path: root/libass/Makefile.am
diff options
context:
space:
mode:
authorOleg Oshmyan <chortos@inbox.lv>2014-04-27 06:55:42 +0100
committerOleg Oshmyan <chortos@inbox.lv>2015-09-17 23:37:10 +0300
commit124a66c69d7362a5b25d3f370a27a74a131c6030 (patch)
tree48b9a7fd181daa6695c547c0587290a5c4f4d315 /libass/Makefile.am
parentd335134ae98fac808d7b1832f4ec87cbc02e217e (diff)
downloadlibass-124a66c69d7362a5b25d3f370a27a74a131c6030.tar.bz2
libass-124a66c69d7362a5b25d3f370a27a74a131c6030.tar.xz
Fully fix compilation with MSVC/ICL
As before, this does not add any build system support: a config.h file and a project must still be manually created (or the compiler can be run manually instead of using a project). Signed-off-by: Grigori Goronzy <greg@kinoho.net> Signed-off-by: Oleg Oshmyan <chortos@inbox.lv>
Diffstat (limited to 'libass/Makefile.am')
-rw-r--r--libass/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libass/Makefile.am b/libass/Makefile.am
index cef1291..cf075bb 100644
--- a/libass/Makefile.am
+++ b/libass/Makefile.am
@@ -30,7 +30,7 @@ libass_la_SOURCES = ass.c ass_cache.c ass_font.c ass_fontselect.c ass_render.c \
ass_drawing.h ass_cache_template.h ass_render.h \
ass_parse.c ass_parse.h ass_render_api.c ass_shaper.c \
ass_shaper.h ass_strtod.c ass_fontconfig.c ass_fontconfig.h \
- ass_string.h ass_string.c
+ ass_string.h ass_string.c ass_compat.h
libass_la_LDFLAGS = -no-undefined -version-info $(LIBASS_LT_CURRENT):$(LIBASS_LT_REVISION):$(LIBASS_LT_AGE)
libass_la_LDFLAGS += -export-symbols $(srcdir)/libass.sym