summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@chown.ath.cx>2015-06-12 21:13:29 +0200
committerGrigori Goronzy <greg@chown.ath.cx>2015-07-10 10:43:16 +0200
commitdf7dd25b26755b6c2a3333cb40172f3642682add (patch)
tree0bb96d76971ec00453959be1ab5fed54443d7834 /configure.ac
parent08a6b1607016ff1855c746b296ab12c1c8a3a0d1 (diff)
downloadlibass-df7dd25b26755b6c2a3333cb40172f3642682add.tar.bz2
libass-df7dd25b26755b6c2a3333cb40172f3642682add.tar.xz
directwrite: fix linking
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac115ea..fe743f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,9 @@ fi
if test x$harfbuzz = xtrue; then
pkg_requires="harfbuzz >= 0.9.5, ${pkg_requires}"
fi
+if test x$directwrite = xtrue; then
+ pkg_libs="${pkg_libs} -ldwrite"
+fi
AC_SUBST([PKG_LIBS_DEFAULT], [$(test x$enable_shared = xno && echo ${pkg_libs})])
AC_SUBST([PKG_REQUIRES_DEFAULT], [$(test x$enable_shared = xno && echo ${pkg_requires})])