summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2009-07-11 03:50:41 +0200
committerGrigori Goronzy <greg@blackbox>2009-07-11 05:34:29 +0200
commitce26c316751e7dbe844d5069731da9de32507ea3 (patch)
tree20bada38ca3b3d9364ba1036bbb7278283746425 /configure.ac
parentcdb60002be244cea09d1efb94db6367a09f95859 (diff)
downloadlibass-ce26c316751e7dbe844d5069731da9de32507ea3.tar.bz2
libass-ce26c316751e7dbe844d5069731da9de32507ea3.tar.xz
autoconf: disable Fortran/C++ checks
For some reason, libtool wants to check for Fortran and C++ compilers, which takes some time. Disable these checks to speed up ./configure runs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4cc0d53..fb09fb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,10 @@ AC_PREREQ(2.60a)
AC_INIT(libass, 0.9.6)
AM_INIT_AUTOMAKE
AC_CONFIG_MACRO_DIR([shave])
-AM_PROG_LIBTOOL
+# Disable C++/Fortran checks
+define([AC_LIBTOOL_LANG_CXX_CONFIG], [:])
+define([AC_LIBTOOL_LANG_F77_CONFIG], [:])
+AC_PROG_LIBTOOL
AC_CONFIG_SRCDIR([libass/ass.c])
AC_CONFIG_HEADER([config.h])