summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@chown.ath.cx>2015-06-14 12:34:09 +0200
committerGrigori Goronzy <greg@chown.ath.cx>2015-07-10 10:43:16 +0200
commit829e2b7e5a3872c8be87dc6bcc23227e2aaaffd6 (patch)
tree0406f9afc7392d9462737b71b80b065d85bfdc2b /configure.ac
parentea349daec2d4261edf1690ae747d4347a0826c71 (diff)
downloadlibass-829e2b7e5a3872c8be87dc6bcc23227e2aaaffd6.tar.bz2
libass-829e2b7e5a3872c8be87dc6bcc23227e2aaaffd6.tar.xz
directwrite: add font fallback callback
This uses a faux rendering with a high-level interface of DirectWrite to determine a suitable fallback. Choices are different from GDI, but reasonable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fe743f9..f07d739 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,6 +179,7 @@ fi
if test x$enable_directwrite != xno; then
AC_LANG_PUSH([C++])
+CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
OLDLIBS="$LIBS"
# Linking to DirectWrite directly only works from Windows
LIBS="$LIBS -ldwrite"