summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2011-02-16 19:39:54 +0100
committerGrigori Goronzy <greg@blackbox>2011-02-16 19:43:29 +0100
commit7a9b40bfe0ec240a7e74b36e2e2f284d00b1023c (patch)
tree94909a9511fb8f735f5cde0b303cc9c2249bcf2c /configure.ac
parented62c02763237146517e8d7a8e0cbc01b717cb41 (diff)
downloadlibass-7a9b40bfe0ec240a7e74b36e2e2f284d00b1023c.tar.bz2
libass-7a9b40bfe0ec240a7e74b36e2e2f284d00b1023c.tar.xz
Require fontconfig by default
Enable configure to require fontconfig by default; libass is quite useless for most purposes without it anyway. If you want to build without fontconfig, explicitly disable it with --disable-fontconfig.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 827dd6c..117b120 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,7 +39,7 @@ AC_ARG_ENABLE([png], AS_HELP_STRING([--enable-png],
AC_ARG_ENABLE([enca], AS_HELP_STRING([--disable-enca],
[disable enca (charset autodetect) support @<:@default=check@:>@]))
AC_ARG_ENABLE([fontconfig], AS_HELP_STRING([--disable-fontconfig],
- [disable fontconfig support @<:@default=check@:>@]))
+ [disable fontconfig support @<:@default=enabled@:>@]))
PKG_CHECK_MODULES([FREETYPE], freetype2 >= 9.10.3, [
CFLAGS="$CFLAGS $FREETYPE_CFLAGS"
@@ -53,7 +53,7 @@ PKG_CHECK_MODULES([FONTCONFIG], fontconfig >= 2.4.2, [
LIBS="$LIBS $FONTCONFIG_LIBS"
AC_DEFINE(CONFIG_FONTCONFIG, 1, [found fontconfig via pkg-config])
fontconfig=true
- ], [fontconfig=false])
+ ])
fi
if test x$enable_enca != xno; then
@@ -71,8 +71,7 @@ PKG_CHECK_MODULES([LIBPNG], libpng >= 1.2.0, [
CFLAGS="$CFLAGS $LIBPNG_CFLAGS"
LIBS="$LIBS $LIBPNG_LIBS"
AC_DEFINE(CONFIG_LIBPNG, 1, [found libpng via pkg-config])
- libpng=true
- ])
+ libpng=true])
fi
AM_CONDITIONAL([HAVE_LIBPNG], [test x$libpng = xtrue])