summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2011-07-10 20:25:35 +0200
committerGrigori Goronzy <greg@blackbox>2011-07-11 13:05:52 +0200
commit778c5cebe439598bf3a6f0277ed7516928f0ff00 (patch)
treebf8c793d6b4338a8fa0f486219c8e5ddbf1dbeb5 /configure.ac
parent4805334bf91444ba7e818145944f8236a64b0563 (diff)
downloadlibass-778c5cebe439598bf3a6f0277ed7516928f0ff00.tar.bz2
libass-778c5cebe439598bf3a6f0277ed7516928f0ff00.tar.xz
Add HarfBuzz checks to build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e73b910..56655ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,15 @@ PKG_CHECK_MODULES([FRIBIDI], fribidi >= 0.19.0, [
])
fi
+if test x$enable_harfbuzz != xno; then
+PKG_CHECK_MODULES([HARFBUZZ], harfbuzz >= 0.7.0, [
+ CFLAGS="$CFLAGS $HARFBUZZ_CFLAGS"
+ LIBS="$LIBS $HARFBUZZ_LIBS"
+ AC_DEFINE(CONFIG_HARFBUZZ, 1, [found harfbuzz-ng via pkg-config])
+ harfbuzz=true
+ ])
+fi
+
if test x$enable_enca != xno; then
PKG_CHECK_MODULES([ENCA], enca, [
CFLAGS="$CFLAGS $ENCA_CFLAGS"
@@ -98,6 +107,9 @@ fi
if test x$fribidi = xtrue; then
PKG_REQUIRES="fribidi >= 0.19.0, ${PKG_REQUIRES}"
fi
+if test x$harfbuzz = xtrue; then
+ PKG_REQUIRES="harfbuzz >= 0.7.0, ${PKG_REQUIRES}"
+fi
AC_SUBST([PKG_REQUIRES])
# Setup output beautifier.