summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2011-09-25 02:18:20 +0200
committerGrigori Goronzy <greg@blackbox>2011-09-25 02:18:20 +0200
commit7393996cfe0136f130a6a23bb9fb6f4ddce82d87 (patch)
tree776a0edebfa7fdb46648611b999c40a59545a29d /configure.ac
parentaf2b0f796376cb940eb5abaa7cec873ef75ccf30 (diff)
downloadlibass-7393996cfe0136f130a6a23bb9fb6f4ddce82d87.tar.bz2
libass-7393996cfe0136f130a6a23bb9fb6f4ddce82d87.tar.xz
pkg-config: tailor libass.pc for static-only builds
Add library and package dependencies to the default (non-private) pkg-config fields for static-only builds. This makes sure the packages and libraries are always picked up and used, even if the --static option is not supplied to the pkg-config commandline.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d9496fc..ddd6d2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,7 +93,8 @@ fi
AM_CONDITIONAL([HAVE_LIBPNG], [test x$libpng = xtrue])
-# Add dependent libraries to pkg-config for static linking
+# add libraries/packages to pkg-config for static linking
+PKG_LIBS="-lm"
PKG_REQUIRES="freetype2 >= 9.6.3"
PKG_REQUIRES="fribidi >= 0.19.0, ${PKG_REQUIRES}"
if test x$enca = xtrue; then
@@ -105,7 +106,11 @@ fi
if test x$harfbuzz = xtrue; then
PKG_REQUIRES="harfbuzz >= 0.7.0, ${PKG_REQUIRES}"
fi
-AC_SUBST([PKG_REQUIRES])
+
+AC_SUBST([PKG_LIBS_DEFAULT], [$(test x$enable_shared = xno && echo $PKG_LIBS)])
+AC_SUBST([PKG_REQUIRES_DEFAULT], [$(test x$enable_shared = xno && echo $PKG_REQUIRES)])
+AC_SUBST([PKG_LIBS_PRIVATE], [$(test x$enable_shared = xno || echo $PKG_LIBS)])
+AC_SUBST([PKG_REQUIRES_PRIVATE], [$(test x$enable_shared = xno || echo $PKG_REQUIRES)])
# Setup output beautifier.
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])