summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2015-10-10 08:11:38 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2015-10-10 20:38:12 +0000
commit4778001b673c73133d7d1dd48a385d0ca424ccfc (patch)
treec20d49e6792574549dbb8e95641701f278a8d776 /configure.ac
parent19d6a9edc2a102a4df56fc2e950459ceb15dd091 (diff)
downloadlibass-4778001b673c73133d7d1dd48a385d0ca424ccfc.tar.bz2
libass-4778001b673c73133d7d1dd48a385d0ca424ccfc.tar.xz
configure: Set the correct x32 machine option for yasm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 117b23b..d6fbe34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,12 @@ AS_IF([test x$enable_asm != xno], [
X86=true
BITS=32
ASFLAGS="$ASFLAGS -DARCH_X86_64=0 -m x86" ],
+ [x86_64-*-gnux32|amd64-*-gnux32], [
+ AS=yasm
+ INTEL=true
+ X64=true
+ BITS=64
+ ASFLAGS="$ASFLAGS -DARCH_X86_64=1 -m x32" ],
[x86_64-*|amd64-*], [
AS=yasm
INTEL=true