summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
author11rcombs <rodger.combs@gmail.com>2013-12-31 11:49:30 -0600
committer11rcombs <rodger.combs@gmail.com>2014-01-25 13:56:06 -0600
commit449ae478ab4263a11766ee7f9e224e4fe8588d69 (patch)
tree298a427ab946148b413700d31d5bb8479c81e137 /configure.ac
parentc55e335fc5dd1d877e1863a38fb48e9dd2072af6 (diff)
downloadlibass-449ae478ab4263a11766ee7f9e224e4fe8588d69.tar.bz2
libass-449ae478ab4263a11766ee7f9e224e4fe8588d69.tar.xz
Added profile program and corresponding configure options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a05cf8f..11c1f79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,8 @@ AC_CHECK_LIB([m], [fabs])
# Check for libraries via pkg-config
AC_ARG_ENABLE([test], AS_HELP_STRING([--enable-test],
[enable test program (requires libpng) @<:@default=no@:>@]))
+AC_ARG_ENABLE([profile], AS_HELP_STRING([--enable-profile],
+ [enable profiling program @<:@default=no@:>@]))
AC_ARG_ENABLE([enca], AS_HELP_STRING([--disable-enca],
[disable enca (charset autodetect) support @<:@default=check@:>@]))
AC_ARG_ENABLE([fontconfig], AS_HELP_STRING([--disable-fontconfig],
@@ -92,6 +94,8 @@ fi
AM_CONDITIONAL([HAVE_LIBPNG], [test x$libpng = xtrue])
+AM_CONDITIONAL([ENABLE_PROFILE], [test x$enable_profile = xyes])
+
# add libraries/packages to pkg-config for static linking
pkg_libs="-lm"
pkg_requires="freetype2 >= 9.10.3"
@@ -114,5 +118,5 @@ AC_SUBST([PKG_REQUIRES_PRIVATE], [$(test x$enable_shared = xno || echo ${pkg_req
# Setup output beautifier.
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-AC_CONFIG_FILES([Makefile libass/Makefile test/Makefile libass.pc])
+AC_CONFIG_FILES([Makefile libass/Makefile test/Makefile profile/Makefile libass.pc])
AC_OUTPUT