summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGrigori Goronzy <greg@blackbox>2011-02-16 19:58:15 +0100
committerGrigori Goronzy <greg@blackbox>2011-02-16 19:58:15 +0100
commitff88d8bdb9bad44230368fb9420c09ecb5b812da (patch)
tree68d043f93c130564c5921ef3575599601ab8b481 /configure.ac
parent7a9b40bfe0ec240a7e74b36e2e2f284d00b1023c (diff)
downloadlibass-ff88d8bdb9bad44230368fb9420c09ecb5b812da.tar.bz2
libass-ff88d8bdb9bad44230368fb9420c09ecb5b812da.tar.xz
test: fix compilation with libpng 1.5, rename configure switch
libpng 1.5 renamed the jmpbuf variable to jmp_buf. Since direct access to this variable is deprecated, it makes more sense to use the function png_jmpbuf() instead. Also, rename the --enable-png switch to --enable-test to make clear this is a debugging option. Initial patch by Alexis Ballier, aballier AT gentoo DOT org.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 117b1204..7e2d8d99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,8 +34,8 @@ AC_SEARCH_LIBS([iconv_open], [iconv], AC_DEFINE(CONFIG_ICONV, 1, [use iconv]))
AC_CHECK_LIB([m], [fabs])
# Check for libraries via pkg-config
-AC_ARG_ENABLE([png], AS_HELP_STRING([--enable-png],
- [enable png (test program) @<:@default=no@:>@]))
+AC_ARG_ENABLE([test], AS_HELP_STRING([--enable-test],
+ [enable test program (requires libpng) @<:@default=no@:>@]))
AC_ARG_ENABLE([enca], AS_HELP_STRING([--disable-enca],
[disable enca (charset autodetect) support @<:@default=check@:>@]))
AC_ARG_ENABLE([fontconfig], AS_HELP_STRING([--disable-fontconfig],
@@ -66,7 +66,7 @@ PKG_CHECK_MODULES([ENCA], enca, [
fi
libpng=false
-if test x$enable_png = xyes; then
+if test x$enable_test = xyes; then
PKG_CHECK_MODULES([LIBPNG], libpng >= 1.2.0, [
CFLAGS="$CFLAGS $LIBPNG_CFLAGS"
LIBS="$LIBS $LIBPNG_LIBS"